Arena issue identified: Slowness of application and Change Modifications Locked

Incident Report for Arena Status

Resolved

The intermittent slowness issue has been resolved.
Posted Dec 09, 2025 - 17:01 PST

Monitoring

A fix has been implemented for Change Modifications and is resolved. We are continuing to monitor slowness in the Quality world specifically.
Posted Dec 09, 2025 - 11:25 PST

Identified

Arena engineering is aware of these issues and is working on them with the highest priority. We will provide updates as they become available.
Posted Dec 09, 2025 - 10:03 PST
This incident affected: app.bom.com.